logo
22.08.2019 08:52
1
Ahoj kluci, trochu jsem se zasekl. Na Eclipse pracuji na některých věcech HTML / PHP / CSS. Vypadá to perfektně v prohlížeči, který je integrován do Eclipse. Pokud však stránku otevřu v prohlížeči Chrome nebo Edge, dostanu velmi odlišné výsledky. Umístil jsem logo na stránku, kterou jsem navrhl sám. V Eclipse vypadá skvěle, ale Chrome i Edge obracejí své barvy a nemůžu najít důvod, jak to funguje v Eclipse! Podobně se moje hypertextové odkazy v Eclipse zobrazují jako slabé (správně), ale v externích prohlížečích jako bílé. Ve své navigaci mám bílé hypertextové odkazy, ale odkazy, které jsou nesprávné barvy, se ani vzdáleně netýkají mé navigace. Nějaká rada?
whatsapp web 192.168.0.1 routerlogin

Co se právě děje na Webtrhu?

22.08.2019 09:09
2
Každý prohlížeč se chová jinak, má jiné chyby a jiné výchozí nastavení, které se ještě k tomu mění se systémem. Udělat web, aby byl identický napříč různými prostředími je skoro vědecká práce. Využívají se k tomu připravené nástroje, které rozdíly sjednocují, např. Bootstrap

Eclipse používá jako interní prohlížeč starý Internet explorer, z toho nejspíš plyne většina tebou popisovaných chyb. Užitečné obecné porovnávní schopností prohlížečů vzhledem k nezávazvými specifikacím lze vidět např. na https://caniuse.com/#compare=ie+11,edge+18,chrome+78

Dokud neukážeš svůj kód, těžko ti dokážeme poradit co přesně děláš špatně. Špatné barvy u obrázků mohou ukazovat třeba na špatný barevný prostor, ve kterém máš obrázek uložený.