logo
08.08.2019 17:14
1
Zdravíčko. Nemohl jsem si povšimnout že pomalu mizí podpora starších verzí php na českých a slovenských hostinzích. Poslední zprávu mám o Websupportu kde to má skončit někdy po prázdninách. Jinde se na to prý taky už pomalu kašle. Je nějaký hosting kde to ještě je a bude podporovaný? V ČR samozřejmě. Ne každý má možnost aktualizovat nějaký starší věci. Dík za info.
08.08.2019 17:25
2
nevím, rušíte se to hodně rychle. Opravdu chce vzít potaz, že php 5.4, 5.5 a 7.0 je ve stavu "end of life" bez dalších oprav, chyby, které v nich mohou být jsou kritické a ohrožují tvoji aplikaci.

Balíčky a zdrojové kódy jsou k dispozici, vlastní provoz je možný a nejspíš se budeš muset časem uchýlit k tomuhle. Případně aplikaci přepsat nebo udělat novou, z hlediska bezpečnosti to je nejlepší.
08.08.2019 17:29
3
Tak to má z hostingu snad kde kdo, ne?


Nebo mi chces tvrdit, ze kdyz si nekdo plati hosting a ma to na 5 php, tak mu to jednoho krasneho dne roku 2019 hostingova firma smaze??


Edit: reaguji na Qestament
08.08.2019 17:32
4
aha, tak očividně tihle jsou dostatečně neaktualizovaní a mají i php 5.2 (podle svých stránek) https://www.cesky-hosting.cz/webhost...y-webhostingu/

zlatomil: oni to nejspíš nesmažou, ale jen přestanou stránky servírovat, protože odstraní podporovanou verzi php či prostě udělat upgrade a stránky přestanou fungovat.
08.08.2019 17:41
5
TomasX obcas by to chtelo i praktictejsi nadhled :)
08.08.2019 17:47
6
gransy: díky :), ale nevím co je menšip zlo, provozovat aplikaci na nepodporované verzi může být stejně drahé jako jí přepsat na novou. Podle googlu pár hostingů je, ale nevím, jestli to také příští rok nezmění.
08.08.2019 18:43
7
Původně odeslal TomášX
gransy: díky :), ale nevím co je menšip zlo, provozovat aplikaci na nepodporované verzi může být stejně drahé jako jí přepsat na novou. Podle googlu pár hostingů je, ale nevím, jestli to také příští rok nezmění.
pristi rok nezmeni nic. Hostingovky se deli na dve skupiny - ty co klienty tlaci do upgradu a ty co maji pochopeni s tim ze spousta z nich uz davno nema vyvojare co jim delal web :D Ty prvni to neresi a proste aktualizuji a ty druhy resi zabezpeceni proti zneuziti na sve strane - tomu rozumnej tak, ze se snazi zabezpecit hosting tak, aby deravy web omezil maximalne daneho klienta a jeho web/weby, nikoliv vsak ostatni uzivatele. Vetsina lidi co vyzaduje starsi verze PHP i toto vedi.

Btw, je to asi dva dny zpatky co me celkem dostalo - nasel jsem jeden US hosting co nabizel PHP od 4.4 do 7.3 :) To uz je fakt hardcore :)

---------- Příspěvek doplněn 08.08.2019 v 17:46 ----------

Jinak jsem zbezne prolitl hostingovky a od PHP 5.3 to nabizi kdekdo: my, wedos, cesky-hosting, best-hosting, ignum, stable, atd ... nektery maj i tu 5.2. Fakt staci google.
08.08.2019 19:07
8
tím se ale mohou zvedat náklady, ano i staré php je možné dobře provozovat a chápu, že přepis aplikací je drahý a snad aplikace zastará dříve než staré php nebude levně provozovatelné.

Ani u jedné ze zmiňovaných společností nevidím, že by starou verzi php měli jako vlastnost, kterou nějakou dobu budou garantovat, aby to člověk nemusi za půl roku znovu migrovat.
08.08.2019 19:46
9
Původně odeslal TomášX

Ani u jedné ze zmiňovaných společností nevidím, že by starou verzi php měli jako vlastnost, kterou nějakou dobu budou garantovat, aby to člověk nemusi za půl roku znovu migrovat.
To že to podporují a to zda to nabízí na svém webu (= lákají na to nové zákazníky) jsou dvě zcela odlišné věci ;-)
08.08.2019 21:37
10
My máme napr. staršie verzie PHP resp. HardenedPHP od CloudLinux. V základe ale nie sú povolené ale dá sa to.
09.08.2019 02:59
11
ceskyhosting, ten asi zrušení 5.2 v plánu nema :D
11.08.2019 00:13
12
Původně odeslal Qestament
Je nějaký hosting kde to ještě je a bude podporovaný? V ČR samozřejmě. Ne každý má možnost aktualizovat nějaký starší věci. Dík za info.
Hezký den. Ano, takových hostingů je stále dost. Včetně nás. Podporujeme a neplánujeme rušit PHP od verze 5.3 výše. Doporučujeme však alespoň 7.1 pokud možno. Nejlépe 7.3. NETIO.CZ
20.08.2019 09:06
13
Hosting Blueboard.cz nabízí verze od PHP 5.3, 5.6 až po 7.3. 5.3 jsou na požádání. Problém se starými verzemi (pokud nebudeme řešit otázky bezpečnostních děr apod) je spíše v tom, že už bývá problém je kompilovat s novými knihovnami apod. I tak se budeme snažit udržet je co nejdéle.
25.08.2019 19:11
14
Webhosting MyDreams.cz také neplánuje zrušit podporu PHP 5.4. a 5.6. Klientům pro nové projekty však doporučujeme PHP 7.2.
PHP 7.3 bohužel obsahuje stále mnoho bugů a tak ho zatím nepodporujeme.

Naši klienti velmi často využívají ioncube loader a ten dobře funguje jen na starších verzích PHP.