Založení a design webu a eshopu taneční školy
Zobrazují se odpovědi 1 až 14 z 14

Joomla a přechod na 7.x

  1. Mám Joomlu verzi 3.8.12. Hostuji na wedosu a v nastavení mám výchozí verze je PHP 7.0. Je tam možnost zvolit 7.1.

    Joomla mi hlásí:
    Verzi PHP, 7.0.19, pouze dostává i pouze informace o bezpečnostnícch opravách od PHP projektu. To znamená, že vaše verze PHP již brzy nebude podporována. Doporučujeme naplánování upgradu na novější verzi PHP, dřív než dojde k ukončení podpory na 3. 9. 2018. Joomla bude rychlejší a bezpečnější, pokud provedete upgrade na novější verzi PHP (PHP je doporučeno 7.x). Pro pokyny k upgradu se obraťte na váš webhosting.

    Verzi databáze 5.6.17
    PHP Version 7.0.19

    Můžete mi poradit, co to po mě chce? Mám zvolit na wedosu verzi 7.1. Budu muset udělat nějaké úpravy nebo je přechod bez problémů?

    Děkuji

  2. Co se právě děje na Webtrhu?
  3. Verzia Joomly ktoru mas by mala byt plne kompatibilna aj s vyssimi verziami PHP (7.1), takze z tohto pohladu to kludne prehod na 7.1.
    Problemom mozu byt komponenty a moduly tretich stran, ktore mozu pri vyssej verzii vykazovat nejaky problem. Myslim si vsak, ze pravdepodobnost je minimalna, horsie by to bolo ak by si prechadzal napr. z 5.6 na 7.x

    Moje odporucanie: Prehod to na hostingu na 7.1 a web otestuj.. ak by sa nieco objavilo, tak to prehod naspat na 7.0 a potom ziskas cas na riesenie daneho modulu tretej strany a jeho nekompatibility. Idealne je vsak aby si taku zmenu samozrejme urobil niekde na localhoste, na testovacom servery a nie priamo v produkcii.

  4. Tak jsem to zkusil přehodit na 7.1 ale web vypisuje tuto chybu na různých místech:
    Warning: Parameter 2 to modChrome_artblock() expected to be a reference, value given in /data/web/virtuals/94192/virtual/www/templates/dd_openmint_25/html/modules.php on line 36

    Vypadá to že je něco ze šablonou, lze s tím něco udělat? Děkuji

  5. Typoval by som že problém nie je s PHP verziou, lebo sedmičková verzia bude ešte dlho predlho podporovaná.

    Skôr si myslím že problém je zastarala databáza.

    Rozhodne bežíš na starej databáze!

  6. V Joomle mi to v systémových informacích vypysuje Verze databáze - 5.6.17. Ta je stará? Jak to přehodit na novější databázi? Děkuji

  7. Je stará a prestáva byť podporovaná.

    na hostingu vytvoriť novú DB, s vyššiou verziou.
    Počkáš 15 min, kým bude dostupná.
    zo starej vyexportuješ celú DB, tá možnosť hostin má.
    potom do novovytvorenej DB na exportuješ údaje.
    v hostingu v Joomla zložke configuration.php prepíšeš nový názov vytvorenej DB a nové heslo

  8. Nemyslim si, ze tato chyba indikuje problem s databazou.
    Ocividne pouzivas sablonu od artisteeru (co teda nie je ziadna vyhra), ktora ma s novou verziou PHP problem.
    Tu mas popisany tvoj problem aj navrh riesenia ako chybu opravit:
    Artisteer Web Designer Forums

  9. Používám šablonu dd_openmint_25 - https://diablodesign.eu/

    DD OpenMint 25 - Diablodesign - Joomla

    Ale asi je to starší verze: <creationDate>2013-06-25</creationDate>

  10. Predpokladam ze starsie verzie tychto sablon robili v artisteeri, mozno aj novsie tak robia.

    Vyskusaj ten navod co som ti daval vyssie, to je asi prve co by som na tvojom mieste urobil.

  11. Čoveče asi mě to pomohlo. To je super díky. Ohledně databáze jsem chtěl přejít na novější a wedos mi odpověděl:
    Pokud potřebujete nějakou konkrétní verzi, napište nám ji, pokusíme se vytvořit db s požadovanou verzí.

    Mám tedy přejít na nějakou novější databázi nebo to nechat na té 5.6.17, na kterou?

  12. Rad som pomohol :)

    Co sa tyka databazy tak moje heslo je: Nehas co ta nepali :)
    Takze ak ti vsetko funguje, a nie si isty, ci by si prekonfigurovanie na novu databazu zvladol (je so sice len uprava v konfiguraku a export do novej DB, ale aj tak) na tvojom mieste by som tu databazu este neriesil. Kvoli obycajnej prezentacnej stranke sa to neoplati.

    Ale ak sa na to citis, tak potom odporucam Mysql 5.7 alebo MariaDB 5.5

  13. Mohli byste mi prosím poradit. Přecházím znovu z PHP 7.2 na PHP7.3 ale web pak vykazuje následující chybu:

    Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /data/web/virtuals/94192/virtual/www/templates/dd_openmint_25/functions.php on line 199

    Můžete mi prosím poradit, co udělat, abych se té chyby zbavil? Děkuji

  14. Je tady někdo, kdo mi může poradit?

  15. Citace Původně odeslal MMMMM Zobrazit příspěvek
    Je tady někdo, kdo mi může poradit?
    Otvor si subor functions.php na riadku 199 a zmen prikaz [continue;] na [break;]

Spolupracujeme: Jooble.org, Aximum - profesionální překlady Hostujeme u Server powered by TELE3