Kvalitní e-mailing již od 0,01 Kč | Vyzkoušejte náš cool e-mailing | coolemailing.cz
Zobrazují se odpovědi 1 až 5 z 5

Jak zkopíkruji makro v jedné buňce do jiné

  1. Ahoj, jak prosím zkopíruji (a lehce upravím) makro v excel sešitu z jedné buňky do druhé? Jsem začátečník.

  2. Co se právě děje na Webtrhu?
  3. Ahoj, nevím na co přesně se ptáš, možná na toto ? :)
    range("A2").value = range("A1").value (vepíše do bunky A2 data z bunky A1)

    popř.
    Range("A2").copy
    Range("A1").select
    Activesheet.paste

    Jinak V Excelu máš možnost zaznamenávat to co děláš (Record macro) a ono ti to vypíše kód, dle toho se dá dobře učit základy :)

  4. dík asi jsem pomalejší, zkusím tedy celé řešení:
    když napíšu do buňky A1 písmo "a" potřebuji aby v buňce i1 se objevilo automaticka "10"
    Jak/kam/jaké makro prosím vložít, najde si někdo zkušenější chvilku prosím?

  5. a chceš psát makro a nebo ti stačí vzorec ?

    Vzorec : Do bunky I1 napis : =If(A1="a";10;"NENASTAVENO) (mozna musíš stredniky vymenit za carky)

    Pokud chces makro tak do modulu napis :
    sub test
    if range("A1").value = "a" then range("I1").value = 10
    end sub

  6. Citace Původně odeslal Dominik94 Zobrazit příspěvek
    a chceš psát makro a nebo ti stačí vzorec ?

    Vzorec : Do bunky I1 napis : =If(A1="a";10;"NENASTAVENO) (mozna musíš stredniky vymenit za carky)

    Pokud chces makro tak do modulu napis :
    sub test
    if range("A1").value = "a" then range("I1").value = 10
    end sub
    super ten vzorec stačí dík, a když tam chci přidat ještě další podmínky když A1 bude b tak 20 + v A1 c tak 30?

    ---------- Příspěvek doplněn 04.06.2018 v 13:04 ----------


    Tak jsem se v tom trochu pohrabal a již to téměř mám, až na poslední podmínku

    =KDYŽ(A723="a";"10";KDYŽ(A723="j";"20";KDYŽ(A72 3="g";"30";KDYŽ(E723="XX";"1000";""))))
    Tak zde mám moji verzi, funguje mi vše pro buňky A, postupně se tam doplnují podmínky. Negunguje mi poslední podmínka pro buňku E.

    V případě kolize (např A = a a zároveň E = XX) tak by měl být výsledek 10

    Mělo by to fungovat tak že prvně platí vše pro A a pokud náhodou v E je XX tak tak by mělo zůstat dle A tedy 10,20,30.

    ---------- Příspěvek doplněn 04.06.2018 v 21:40 ----------

    už mám vyřešeno....................nevíte někdo jek lze zvednout počet podmínek if?
    Naposledy upravil koicz : 04.06.2018 v 14:16

Hostujeme u Server powered by TELE3